Start a Chat Sales: 0800 862 0890 Client Area
Results 1 to 7 of 7

Thread: importing large files over 50MiB

  1. #1
    timbo10 is offline new member
    Join Date
    Oct 2010
    Posts
    2

    Default importing large files over 50MiB

    Hi, ive got a problem and hoping someone can help me...

    I'm the process of importing a database, the problem is that the file limitation is too small.


    Is there a way I can access the config.inc.php which is located in the phpmyadmin directory.


    I've got round the large file problem before by using this method...


    Changing this line..


    $cfg['UploadDir'] = '';


    in the config.inc.php file to


    $cfg['UploadDir'] = 'upload';


    Create a directory called ‘upload’ within the phpmyadmin directory.


    Place the large sql file into the new upload directory.


    Change the maximum execution time in the config.inc.php


    I'm unsure if this possible, because I've only used this method on my local server.

  2. #2
    sysadmin's Avatar
    sysadmin is offline Administrator
    Join Date
    Oct 2006
    Posts
    325

    Default

    Hi,

    It's recommended to upload the large .SQL files to your dedicated server & then import them directly using the mysql.exe (Windows) or mysql (Linux) commands.

    Syntax:
    mysql MyDB < path\to\LargeSQLFile.SQL

  3. #3
    VConnor is offline Moderator
    Join Date
    Oct 2009
    Posts
    26

    Default

    Hello,

    If your account/domain is hosted on a shared server then, we won't be able to provide you the access of config.inc.php of PhpMyAdmin.

    As you want to import large files over 50MB or greater than that then, you won't be able to do it from phpmyadmin.

    You can upload that database backup file in .sql format under your web space you've with us and ask us to restore that file fro your specific database, so that it will be done in few minutes for you.

    You can also contact us for this work on our live chat assistance which is 24x7..

  4. #4
    timbo10 is offline new member
    Join Date
    Oct 2010
    Posts
    2

    Default

    Thank you very much for your advice, I'm going to upload the .sql file to my ftp then contact you guys to restore the file to the specific database.

    Cheers

    Tim

  5. #5
    VConnor is offline Moderator
    Join Date
    Oct 2009
    Posts
    26

    Default

    Hi Tim,

    It seems you've already initiated an email for this database restore with ticket ID #EIM-37718-697. I've just replied to your ticket. Please check it and furnish it with the requested details to get this work done.

  6. #6
    webscott is offline System Administrator
    Join Date
    Nov 2008
    Posts
    40

    Wink

    Hi,

    I've fixed this problem. "InnoDB" database engine needed enabled on the vps. I've enabled it and restored the database file uploaded.
    Best Regards,
    Scott
    System Administrator

  7. #7
    Pumazooma's Avatar
    Pumazooma is offline Senior Member
    Join Date
    Jun 2006
    Location
    Oxford
    Posts
    338

    Default

    There's a good application called bigdump that can do that
    BigDump: The Staggered MySQL Dump Importer

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Copyright 2001-2013 Web Hosting UK. All rights reserved.